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Introduction 
EmpirBus studio is a software developed to be used to build logical functions for EmpirBus systems. 
The logical functions will execute commands that control the EmpirBus modules input and output 
channels as well as integrating it to third party systems. All channels can be configurated in this 
software. It can be used to build advanced logical functions, set fuse size for outputs, build virtual 
buttons, convert and present analog sensor data, set alarm conditions and much more. This is a 
simple, yet powerful software where imagination and creativity probably will be the biggest 
limitation. 
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Installation 
To Install the software, use the following link: 

http://updates.EmpirBus.com/clickonce/EmpirBusStudio-Demo/ 

 

When the installation has been completed, download the latest firmware. The latest firmware can be 
found on the following webpage: 

https://www.EmpirBus.com/#firmware 

 

When the software has been installed and the firmware is downloaded. The next step will be to 
import the firmware. 

1. Open EmpirBus studio. 
2. In the EmpirBus studio, click on “File” in the top menu and select “Close Project”. 
3. Click on “Settings” in the top menu and select “Import Firmware”. 
4. A new window will open. Press “Choose File” and select the downloaded firmware file. 
5. Click import. 
6. A message will inform that the firmware has been successfully imported. 

 

Note: Whenever a new firmware is available, a popup will inform the user when EmpirBus studio is 
opened. There is no need to manually look for new updates. 

 

 

The EmpirBus studio software is now ready for use. 

 

  



Quickstart Guide EmpirBus Studio, 2020-10-19 5 

EmpirBus studio 
 

Overview 

 

 

Starting from the left side there is the components menu. All the different components are listed in 
this menu and grouped together to make it easier to find each component. Components could be 
described as the building blocks that are used to build the logical functions. 

Below the components, a window is displaying the available description for each component.  

Note that there is also a statistics menu (below the component description) which can be activated 
by pressing “View” in the top menu and then select “Statistics”. The statistics window can be helpful 
when creating a large project where there is a need to keep track of how many components that 
have been used and how much memory there is left. Note also that several windows are available 
through the “View” menu in case any of the windows should close by mistake. 

The logic schema can be found on the center of the screen. This is the area where the components 
and channels will be placed and linked together. 

The log viewer is located below the logic schema. The log viewer is a tool that can be used to log 
channel statuses. See the log viewer section for more info. 

On the top right side, the project explorer can be found. This is where the project units are added 
and listed (e.g. displays, DCM or connect 50 units, panels etc.). When expanding a unit, all channels 
related to that unit will be visible and can then be added to the logic schema and modified via the 
properties menu below the project explorer. The properties window is used to adjust the settings of 
a selected channel or component. Unnecessary  
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Features 
 

Adding units 
To add a unit (e.g. DCM), click the “Add unit” button in the project explorer. Select “DC I/O modules” 
> “DCM-CCM” and then select the model that match the physical unit. The model number can be 
used as reference. When the unit have been added, it can be renamed. This can also be done later by 
selecting the unit and change the name in the properties window. 

The same procedure is used to add SP12 / SP8 panels, multifunctional displays (MFD), programming 
interface or MCU. In order to add channels that are used as buttons or indicators on the MFD, an 
MFD unit will need to be added.  

In order to load the configuration, the system will need to have a master unit. An MCU, DCM or a 
Connect 50 can be used. In the project explorer, select the unit that should be used as a master unit. 
Drag and drop the whole unit out into the logic schema. Select the unit in the logic schema and look 
at the properties window. It should be set as master and not slave. When the unit is set as master, it 
will say “(Master)” right after the unit name in the project explorer. Keep in mind that system 
limitations changes depending on which unit that has been selected to be master. 

 

Adding components 
The components are located on the left-hand side. They are all grouped together in different 
categories to make it easier to find them. For new users the most common components used to build 
simple logic can be found under “Control Modules”, “General Components” and “Logic Gates”. Drag 
and drop the component into the logic schema. The properties window will display the available 
settings for each component whenever the component is selected. The pin(s) on the left side of the 
component are the signal(s) that goes into the component. The pins(s) on the right side of the 
component is the signal that have been processed by the component. 

  



Quickstart Guide EmpirBus Studio, 2020-10-19 7 

 

Adding input or output channels 
Input and output channels are referred to as “I/O”. These are the actual channels that are physically 
available on the unit. E.g. if the project includes a DCM, it would have 16 channels total. Some of 
these channels can be used only as input or output while some can be used as both depending on 
how they are configurated in the properties window and which unit type that are used. In order to 
add a channel, a unit must first be added to the project. 

Go to the chapter “Adding units” and add a unit before proceeding to add channels. 

Once a unit have been added, select the unit in the project explorer and expand it. Also expand the 
“I/O Channels”. The green and blue arrows indicate if they are inputs or outputs where green are 
inputs and blue are outputs. To add an output (for example to drive a light), simply drag and drop it 
into the logic schema. As soon as the channel is released into the logic schema, a menu will appear 
where different channel settings can be set. By selecting “Plus (+)” the channel will be programmed 
to be an output that will drive the external load (e.g. lights). 

 

To learn more about different channel types and settings, watch this video. 

 

The above procedure is used for all units, even the SP8/SP12 panels or multifunctional display (MFD). 

 

 

Properties 
The properties window is used to set the properties for each component or channel. Different 
settings will be available depending on the currently selected object. The properties window is 
frequently used while programming. It is a good idea to keep an eye on this window whenever a new 
component or channel is added to the logic schema. 
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Create connections between components 

 

Figure 1 : Circuit with 3 buttons controlling one output (Light). 

In the figure 1 above, three different buttons are used (an MFD unit is needed to access channels 
used for virtual switches) to control one output which in this example are connected to a light. The 
PBC in the middle are used to keep the signal fixed at ON or OFF as the buttons only gives a pulse for 
each press. Note that the PBC in the example above have been expanded through the properties 
window with a total of 3 pulse buttons. To connect the button to the PBC, simply press on the right-
side pin of the button called “Button pressed”. A connection line between the pin and the cursor will 
appear. The connection line can now be either drawn straight to the left top pin of the PBC named 
“Pulse button 1” or through a specific path by clicking on several different points in the logic schema 
until finally connecting it to the PBC (“Pulse button 1”). Drawing a specific path is just to visually 
make it easier to follow the connection line. If a connection line needs to cross another (already 
existing) connecting line, then there is no limitation to do so. The connection lines won’t connect to 
each other but will only connect between the two points (pins) that have been selected as start and 
stop point. 

To delete a line (while drawing), press ESC. 

To delete a line (that is already drawn), select it and press DEL. 
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Set connection line color 
It can be helpful to label connections or grouping them together. Sometimes, it can be easier to 
follow each connection if they have specific colors. For example, red color can be used for OFF signals 
and green color for ON signals. Line colors are only used to give a better overview visually and does 
not affect the logic. 

 

Figure 2 : Using colors on connections. 

To set color, select a connection line and right click on it. Select “Set color”. Choose a color and press 
OK.  

If the connection line needs to be changed back to its original color, then choose the black color. 

It is also possible to set a different color than black as default. Select a color and press “Set as 
default”. Every new connection will be drawn with the selected color. 
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Rectangles 
Rectangles can be used to highlight a specific area or function. It can be a helpful tool in a larger 
configuration when there are a lot of things to keep track of. 

 

Figure 3 : Right click and select create rectangles. Left click and drag the corners to resize the rectangle. 

 

Textboxes 
Textboxes can be very helpful when overviewing the whole project. Textboxes can be used to mark 
specific functions or even specific connections. 

  

 

Figure 4 : Creating a textbox 
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Right click on an empty area on the logic scheme and select “Create textbox”. A new window will 
open where the text can be edited. Enter the text and press OK. The textbox will appear in the logic 
schema. Textboxes can be moved around and placed wherever in the logic schema. 

 

Tabs 
 

 

 

Tabs can be added to split up the logic schema. Right click on it and choose properties. It is now 
possible to change name and order in the properties window. To create a new tab, click on “Add”. 
The benefit with several tabs is that different functions can be separated. Note that no matter how 
many tabs there is in the project, they will still be within the same config file and project. In other 
words, the project can be drawn on several different tabs, or only on one tab. It will function the 
same. The tabs are there only to make it easier for the programmer. 
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Portals 
Portals are used to make a connection between two points if the components are far away from each 
other or if the components are drawn on different tabs. Rather than drawing a very long line a portal 
can be used instead. In the example below, a button with ON/OFF pulse has been added to a portal. 
As soon as a portal and signal (connected to the specific portal) have been created, an instance of a 
portal can be created to output the signal. An instance of a portal can be created unlimited times and 
be used on several different locations. Even on other tabs. 

 

Figure 5 : Right click on an empty area and select "Create new portal". Give the portal a name and press OK. 

 

 

Figure 6 : Draw a new connection, in the above case from the button ON/OFF pulse pin and connect it to the portal. Give the 
signal a name within the portal. Right click on an empty area in the logic schema and select “Create instance of portal”. 
Select the portal that was created. The portal will now appear in the logic schema. 

 

 

Figure 7 : Click on the right-side pin of the portal. A list of all the available signals will open. Select signal and click OK. A 
connection line will appear and can now be connected to a component pin. In this case to the PBC. 
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If a connection is drawn between two pins or if it is drawn between two pins with the help of a portal 
will result in the exact same function. The benefit with the portal is that it reduces the lengths of 
connection lines and makes the logic easier to follow. It can be wise to use the portal to collect 
several different signals if they all should be outputted at the same place. Useful to collect alarm 
signals from multiple alarm components which might be outputted to one single output (e.g. a 
buzzer). 

It is recommended to name the signals with a word that describe the type of signal e.g. fixed or 
pulse. This will help a lot when using the signals in the other end. 

The use of portals can sometimes lead to confusion if there are many portals and signals to keep 
track of. Sometimes it can be necessary to verify which component a specific signal origin from. To 
get this kind of information there is an option called “Find origin”. To find the origin of a signal, select 
and right click on the signal. Select “Find origin”. This will mark the component of which the signal 
origins from. If all references are needed, right click on a specific signal and select “Find all 
references”. This will open a window which will show every place in the config where the specific 
signal is being used. 

 

Snippets 
A snippet is used to export a selection of components. It can be a complete function or a part of a 
function. To create a snippet, select the components and I/O channels that should be included in the 
snippet (also works for text and rectangles). Hold down CTRL while selecting components to select 
them one by one. When the components have been selected, click “Edit” > “Save snippet”.  

It is also possible to right click on one of the selected components to access the “Save snippet” 
option. Give the snippet a name and click on save. Whenever this specific set of components needs 
to be accessed, click on “Insert snippet” which can be found either under the “Edit” menu or by right 
clicking on an empty area in the logic schema and select “Insert snippet”. Logic blocks can be saved 
for later use. Snippets can also be downloaded from a snippet library which can be helpful. Download 
the library here. 

 

Print 
It is possible to print a part of the Logic schema or the channel name together with the channel 
settings. The size of the logic schema is unlimited, meaning that logical blocks can be built vertically 
or horizontally at an unlimited area. To avoid that a logic schema that contains too many 
components are printed, there is a limit of how large area that can be printed. Activate the printing 
area by clicking on “View” and then on “Print area”. A rectangle will appear in the top left corner of 
the logic schema. The rectangle symbolizes the paper. Fit the components inside the rectangle and 
click on “File” > “Print” in order to print. Note that the print size can be changed to A3 if needed.  
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Short commands 
Delete already drawn connection DEL 
Delete connection, not yet connected ESC 
Add anchor point on connection line ALT+Left click (On connection line) 
Move Hold SPACE+Left click and drag 
Zoom Hold CTRL+Scroll 
Zoom area Hold CTRL+select area (hold left click and drag) 
Copy CTRL+C 
Paste CTRL+V 
While drawing connection, hold to create 45-
degree angles 

SHIFT 

Select multiple components Hold CTRL+Left click 
 

 

WDU Finder 
The WDU finder is a tool included in the EmpirBus studio which is located under “Tools” in the top 
menu bar. It is used to find the WDU’s IP address. Once the PC is connected to the WDU with the 
ethernet cable or wifi, it will be listed here for easy access.  

 

 

Log viewer 
The logviewer can be found on the bottom of the EmpirBus studio software (see overview on page 
6). The log viewer is used to see I/O status and sensor values in real time. Different massages can also 
be filtered. 
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Uploading process 
 

 

Figure 8 : System example. 

 

In order to connect a PC to the NMEA2000 network, which contain all units, one of the following 
interfaces must be used: 

- MCU 
- Programming interface 
- Kvaser Leaf Light v2 
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Connect to EmpirBus system 
Once the interface is connected to the PC it will show up in the top toolbar. If not, check connection 
and make sure the drivers have been installed properly (Kvaser only). 

 

 

Set unit ID’s 
In the top menu, click “Communication” > “Set system unit IDs”. The software will start to scan for 
units. If two units have the same ID, there will be a conflict within the system. All units must have a 
unique ID. The easiest way to do this is to physically look on the units and write down the serial 
numbers and ID on a paper and then set ID’s here with the serial numbers as reference. 

 

 

Upgrade firmware 
In the top menu, click “Communication” > “Upgrade firmware”. The software will start to scan for 
units and tell which units that need to be updated. Update all units that need to be updated. Note 
that the master unit must be updated individually and it is recommended to start with the master 
unit. If the update fails, try to update one unit at a time. Note that this step will only be needed the 
first time when uploading a config to the system. 
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Load configuration to EmpirBus system 
In the top menu, click “Communication” > “Send configuration”. The software will start to search for 
the available units and list the units on the left side labeled “System units”. On the right side, labeled 
“System units” there is a list of all the units that have been added to the project (the units added in 
the project explorer). Normally the software will match each unit automatically if the unit IDs and 
serial numbers match. If not, they need to be matched manually. To match the units manually, drag 
and drop the units from the left side list to the right-side list. If the match were successful, then the 
unit will appear in the middle as “Matched units”. This step will only have to be done the first time. 
Next time this will happen automatically. 

Sometimes the programmer has a reason to upload the configuration to the system without one or 
two units while testing the system. That will result in a match warning that will be displayed on the 
left bottom side of the “Send configuration” window. To upload the configuration despite the match 
warning, check the “Ignore match warnings” checkbox which will allow the user to press “Send”. 

 

 
 

When the matching has been done, click “Send”. Once the config has been successfully loaded, the 
master will reboot. 
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Hardware 
To get more information about our system, please visit our website where datasheets, manuals and 
much more can be found. 

https://www.EmpirBus.com/ 

 

Terms of use and best practice 
https://www.EmpirBus.com/wp-content/uploads/EmpirBus-Digital-Switching-Systems-Terms-of-Use-
Best-Practice.pdf 

 

Support 
A lot of useful information can be found on our website. In case answers can’t be found there, feel 
free to contact us anytime by phone or email. 
 
Website 
https://www.EmpirBus.com/#faq 
https://www.EmpirBus.com/#support 
 
Email: 
Support@EmpirBus.com 
 
Phone:  
+46 522 44 22 22  
8 am to 5 pm (CET/CEST), Monday to Friday 


